АдминистрированиеНовости

Новая уязвимость угрожает всем версиям Docker, и патча пока нет

Инженер Suse Алекса Сараи (Aleksa Sarai) обнародовал информацию о новой уязвимости CVE-2018-15664, которая представляет угрозу для всех версий Docker. Состояние гонки позволяет атакующему получить доступ на чтение и запись для любого файла на хосте. К своему отчету специалист приложил proof-of-concept скрипты для эксплуатации бага, которые позволяют осуществить атаку из контейнера и изменить файлы на хост-машине.

Исследователь объясняет, что свежий баг относится к типу time-to-check-time-to-use (TOCTOU), и в сердце проблемы – функция FollowSymlinkInScope, которая оказалась уязвима перед атаками TOCTOU. Задача данной функции – безопасный резолвинг путей, таким образом, будто процессы находятся внутри контейнера Docker. Сараи пишет, что используя утилиту docker cp и символические ссылки, функцию FollowSymlinkInScope можно атаковать, и в итоге путь злоумышленника резолвится на хосте с root-привилегиями.

Патча для этой проблемы в настоящее время нет, хотя работа над исправлением уже ведется. Сараи пишет, что надежных способов защиты от уязвимости не существует, а в качестве исправления советует модифицировать chrootarchive таким образом, чтобы все операции архивирования выполнялись с rootfs в качестве с root’а.

Ваш e-mail не будет опубликован. Он потребуется для подтверждения Вашего поста.
Оформление текста Нажмите «Ввод», чтобы отправить ответ.