Информационная безопасностьНовости

Опубликован эксплоит для бага в runC, угрожающего Docker, Kubernetes и не только

На прошлой неделе стало известно, что  в инструменте для запуска контейнеров runC была обнаружена опасная уязвимость (CVE-2019-5736).

Напомню, что баг позволяет вредоносному контейнеру перезаписать исполняемый файл runC на хост-системе, при этом взаимодействие с пользователем требуется минимальное. Таким образом атакующий может получить root-доступ к хосту и возможность исполнять произвольный код. Специалисты RedHat предупреждали, что эта проблема может спровоцировать настоящий судный день в корпоративном ИТ, ведь через эксплуатацию этого бага потенциальные атакующие могут «достать» и другие связанные с хост-системой решения, то есть может произойти целая цепочка взломов.

Из-за высокой опасности бага эксплоит не был обнародован на прошлой неделе: исследователи давали разработчикам и пользователям больше времени на выпуск и установку патчей. Свои продукты уже обновили  разработчики AmazonGoogleDockerRHELFedora и Ubuntu; идет работа над исправлениями для Debian и SUSE; представители Red Hat пишут, что Red Hat Enterprise Linux и Red Hat OpenShift по умолчанию защищены, и дают советы по обходу проблемы.

Также об уязвимости перед багом сообщили и представители VMware, подготовив соответствующие «заплатки». Специалисты Cisco по-прежнему проводят расследование и устанавливают, какие продукты оказались под угрозой (пока известно лишь, что уязвимость не касается Cisco Metacloud).

Как и было обещано, сегодня, 18 февраля 2019 года, эксплоит для CVE-2019-5736 был опубликован на GitHub. Это лишь один из сценариев использования проблемы: для работы эксплоита атакующему требуется root (uid 0) внутри контейнера.

Ваш e-mail не будет опубликован. Он потребуется для подтверждения Вашего поста.
Оформление текста Нажмите «Ввод», чтобы отправить ответ.