Информационная безопасностьНовости

В WordPress найдена критическая уязвимость шестилетней давности

Эксперты RIPS Technologies обнаружили уязвимость в WordPress, которая позволяет выполнить произвольный PHP-код на сервере и затрагивает почти все версии CMS, выпущенные за последние 6 лет.

Проблема представляет собой комбинацию двух отдельных багов: обхода каталога (Path Traversal) и «включение» локального файла (Local File Inclusion). Корень уязвимости заключается в том, как система управления изображениями WordPress обрабатывает записи Post Meta, которые хранят информацию об описании, размере, создателе изображения и прочие мета-данные загруженных картинок. Из-за бага оказалось возможным модифицировать эти записи, присвоив им произвольные значения и осуществив атаку на обход каталога.

К счастью, есть и хорошая новость: для эксплуатации бага атакующему необходимо иметь учетную запись уровня «Автор» (Author), и неаутентифицированное использование уязвимости невозможно.

Разработчики WordPress уже подготовили патч, однако пока он еще не доступен для широкой публики. При этом специалисты RIPS Technologies объясняют, что уязвимость не получится эксплуатировать уже в версиях новее 5.0.1 и 4.9.9, так как исправления для других проблем мешают воспользоваться багом в полном объеме. При этом уязвимость обхода пока каталога по-прежнему актуальна.

Ваш e-mail не будет опубликован. Он потребуется для подтверждения Вашего поста.
Оформление текста Нажмите «Ввод», чтобы отправить ответ.